Some services are down
Incident Report for Watermelon
Resolved
Our development team has resolved the issue. If you continue to experience problems, please let us support team known via email to support@watermelon.co. We apologize for any inconvenience
Posted Mar 23, 2020 - 01:05 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 22, 2020 - 18:08 CET
Investigating
We are currently investigating this issue
Posted Mar 22, 2020 - 13:59 CET
This incident affected: Watermelon platform.